外付けで動いていたものを内蔵に移す。

sd2 から sd0 に写す。
○ edlabel /dev/rsd0c で同じ区画をする
      root@tateyama  21:26:55/980628(/home/makoto)# edlabel /dev/rsd0c
      edlabel menu:
      print   - display the current disk label
      modify  - prompt for changes to the label
      write   - write the new label to disk
      quit    - terminate program
      edlabel> p
              type_num: 4
              sub_type: 0
             type_name: SCSI disk
             pack_name: fictitious
          bytes/sector: 512
         sectors/track: 71
       tracks/cylinder: 2
             cylinders: 2337
      sectors/cylinder: 142
      partition      start         (c/t/s)      nblks         (c/t/s)  type
      
       a (root)          0       (0/00/00)      29820     (210/00/00)  4.2BSD
       b (swap)      29820     (210/00/00)      85200     (600/00/00)  swap
       c (disk)          0       (0/00/00)     331854    (2337/00/00)  unknown
       d (user)     115020     (810/00/00)     163300    (1150/00/00)  4.2BSD
       e (user)          0       (0/00/00)          0       (0/00/00)  unused
       f (user)          0       (0/00/00)          0       (0/00/00)  unused
       g (user)          0       (0/00/00)          0       (0/00/00)  unused
       h (user)     278320    (1960/00/00)      53534     (377/00/00)  4.2BSD
      edlabel> q
○ newfs で File System を作る
   root@tateyama  21:27:28/980628(/home/makoto)# newfs /dev/rsd0d
   など a d h に繰返す
○ 一時的に mount して dump | restore で写す
   など。
   root@tateyama  21:30:53/980628(/mnt)# dump 0f - /dev/sd2d | restore rf -
   これも a d h に繰返す
○ /etc/fstab を直しておく sd2 -> sd0
○ multi-user では 次のように installboot は出来ない
# ./installboot -v -h /mnt/ufsboot bootxx /dev/rsd0a

root@tateyama  21:50:34/980628(/usr/mdec)# ./installboot -v -h /mnt/ufsboot bootxx /dev/rsd0a
boot: /mnt/ufsboot
proto: bootxx
device: /dev/rsd0a
bootxx: entry point 0x240000
proto bootblock size 3584
room for 64 filesystem blocks at 0x240b94
Will load 1 blocks of size 8192 each.
0: 416
installboot: open: /dev/rsd0a: Device busy

○ 次のように miniroot を内蔵の b 区画に写す
# dd if=miniroot of=/dev/rsd0b bs=32k conv=sync
256+0 records in
256+0 records out
8388608 bytes transferred in 26 secs (322638 bytes/sec)

○ halt
syncing disks... 3 3 1 done
Kernel halted.

Abort at 0xF80B56BA.

○ reset
>k 2
○ miniroot で boot
>b sd(0,0,1) -sw
Boot: sd(0,0,1) -sw
....
....
Enter pathname of shell or RETURN for sh: 
intr ^C kill ^U erase ^? werase ^W newcrt
To install NetBSD, enter the command:  install
Otherwise, enter the command:  halt
# 
○ installboot をする。
# cd /usr/mdec
# mount /dev/sd0a /mnt     
# mount /dev/sd0d /mnt/usr
# ./installboot -v -h /mnt/ufsboot bootxx /dev/rsd0a 
boot: /mnt/ufsboot
proto: bootxx
device: /dev/rsd0a
bootxx: entry point 0x240000
proto bootblock size 3584
room for 64 filesystem blocks at 0x240b94
Will load 1 blocks of size 8192 each.
0: 416
# 
○ halt して、k 2 して、break を送って、

# sync
# sync
# sync
# halt
Jun 28 13:00:39 init: kernel security level changed from 0 to 1
syncing disks... done
Kernel halted.

Abort at 0xF80B56BA.
>b

Watchdog Reset!
>k 2
EEPROM: Using RS232 A port.
Selftest Completed.

Sun Workstation, Model Sun-3/80 Series.
ROM Rev 3.0, 16MB memory installed, Serial #17280.
Ethernet address 8:0:20:7:8A:17, Host ID 42004380.


Testing 16 Megabytes of Memory ... \
telnet> send brk
-
Abort at 0xFEFEC9C8.
>b sd(0)    
Boot: sd(0,0,0) 
>> NetBSD ufsboot [$Revision: 1.1.1.1 $]
843700+38300+70616+[62472+70908]=0x109230
.....
○ eeprom で起動 disk を変更しておく
root@tateyama  22:08:51/980628(/home/makoto)# eeprom 'bootdev=sd(0,0,0)'
bootdev=sd(0,0,0)