hns - 日記自動生成システム - Version 2.19.9

先月 2009年05月 来月
1 2
3 4 5 6 7 8 9
10 11 12 13 14 15 16
17 18 19 20 21 22 23
24 25 26 27 28 29 30
31
Namazu for hns による簡易全文検索
詳しくは 詳細指定/ヘルプを参照して下さい
検索式:

2009年05月20日(水) 旧暦 [n年日記] [更新:"2009/05/22 11:39:53"]

#1 [NetBSD] NetBSD/evbarm has problem for raidctl

I have some problem setting up NetBSD/evbarm on TeraStation Pro (Rack mount).
I will explain some story I've got so far.

First of all, the model I am struggling with, is TS-RH2.0TGL/R5

The one important thing is the serial console is enabled by pushing special red button at the same time you push the power button (The red button is sitting in the panel, you will find it by opening front cover, hidden below LCD display).

I have the

supposedly work on this machine.
I have setup BOOTP and TFTP server to support this.
After getting U-boot prompt with typing any key at certain timing:

Booting from Device 1 
hit any key to switch tftp boot.
Hit any key to stop autoboot:  0 
switched to TFTP boot.
<<system_bootend>>
Hit any key to stop autoboot:  0 
Marvell>>
I have typed 'bootp 8000; g 8000'.
The machine is netbooted by reading gunzipped
netbsd-KUROBOX_TERA_INSTALL.bin.gz
and sysinst starts as the right photo.
But before starting sysinst, I had to try RAID5 setup.

The first problem was that (1) raidctl -iv hang. It is Ram-disk environment. Control-T doesn't work. And there is no way to know what is happening, the only way to stop is 'Power On Reset'.

So I decided to install everything / on wd0a without RAID setup.

Everything goes smoothly. I needed to swap kernel from ram-disk version to normal kernel to boot. While booting with normal kernel, it detects the trace of RAID5 setup. and it claims problem reading RAID5.

So I have booted ram-disk version again and trying to un-configure by 'raidctl -u raid0'. But it again freezes.

One thing I have to try wipe out the trace of RAID,

dd if=/dev/zero of=/dev/rwd0a count=63
But I think it still there.

I remember I have typed /dev/null instead of /dev/zero ... BAD .. I have typed following for this time.

# dd if=/dev/zero of=/dev/rwd0c count=63
and then restor the label by using stored old label: (/tmp/ss)
# disklabel -R wd0 /tmp/ss
disklabel: ioctl DIOCWDINFO: No disk label on disk;
use "disklabel -I" to install initial label
Then I did:
# disklabel -iI /dev/rwd0c
partition> W
Label disk [n]? y
Label written
partition> Q
# disklabel -R wd0 /tmp/ss
(Also, I have to erase disklabel at least two. One is not enough).



最近の日記
2017年10月22日
lang/rustc 1.20.0 still fails at bootstrap
2017年10月15日
wip/rust
2017年10月14日
オイル交換
2017年10月09日
散髪
2017年10月06日
wip/emacs-w3m-cvs
以上、1 日分です。
タイトル一覧
カテゴリ分類
Powered by hns-2.19.9, HyperNikkiSystem Project

Count.cgi (since 2000/02/05)