packages | macppc/pkg | macppc/pkgsrc.shtml
NetBSD2 | NetBSD | 1.6 | amd | autoconf | apache | bind | booting | boot/install/disk | boot-cd | build.sh | (daily) | Canna | CF+sendmail | cvs | dhcpd | dvi2ps | emacs-20 | ftpmirror | fvwm2 | gcc | gettext | ghostscript | inn | IPv6 | jitterbug | Install(OHP) | kernel | (old) | majordomo | make build | MHonArc | MRTG | namazu | ndtpd | PHP + PostgreSQL | netatalk | netboot | NFS | NIS | ntp | opie | Open Firmware | perl | procmail | sendmail | sharutils | smtpfeed | tcsh | TeX | time make | ucspi-tcp | w3 | wget | Wnn | wu-ftpd | X11 | Site Map |
全文検索

NetBSD Packages

URL

Packages(日本語)
http://www.jp.netbsd.org/ja/JP/Documentation/Packages/
Packages(英語)
packages とは何か。実行形式の設置、pkgsrc の使い方、が書いてある。
http://www.jp.netbsd.org/ Documentation/ software/ packages.html
一覧表 http://www.jp.netbsd.org/ja/JP/Documentation/Packages/list/README.html
pkgsrc.tar.gz
ftp://ftp.dti.ad.jp/pub/NetBSD/NetBSD-current/tar_files/ pkgsrc.tar.gz
pkgsrc/www
ftp://ftp.netbsd.org/pub/NetBSD/packages/pkgsrc/www/README.html
pkgsrc/www/communicator
ftp://ftp.netbsd.org/pub/NetBSD/packages/pkgsrc/www/communicatior/README.html
上記の pkgsrc.tar.gz を /usr で開けて、例えば (lang/) perl 5 だとすると、
cd /usr/pkgsrc/lang/perl5 してから make; make install すればいい
その時に必要なものをもし予め持っているなら
/usr/pkgsrc/distfiles/
に置いておけばいい

Netscape-4.7 を i386 に入れて見る

要約版

(root 権限で作業する) pkgsrc.tar.gz を /usr で開ける 次のところに cd して make すればいい pkgsrc/lang/perl5/ pkgsrc/pkgtools/pkg_install しかし ===> pkglint-2.06 depends on installed package: perl-* - perl-5.00404 found のように言われてしまう。 /usr/pkg/bin/perl5.00404 という名前のせいか ln /usr/pkg/bin/perl5.00404 /usr/pkg/bin/perl-5.00404 (これは無効) ===> Registering installation for pkglibtool-1.2p2 と言うので perl の前にこれを入れておく必要があるのかな -- 多分違う (とり敢えず、そのままで次に行く) pkgsrc/pkgtools/ pkgsrc/www/communicator/ の順で入れる /usr/pkg/bin が $PATH に入っていることを確認して rehash して communicator と入力すると、動く。

冗長版

ftp://ftp.jp.netbsd.org/pub/NetBSD/packages の中に次のようにあるはずなので、
drwxrwxr-x  11 mirror  ftpadmin    512 May 10  1999 1.3
drwxrwxr-x   3 mirror  ftpadmin    512 May 29  1998 1.3.1
drwxrwxr-x   6 mirror  ftpadmin    512 May 10  1999 1.3.2
drwxrwxr-x   6 mirror  ftpadmin    512 Feb  1  1999 1.3.3
drwxrwxr-x   8 mirror  ftpadmin    512 Mar  3 13:42 1.4
drwxrwxr-x   7 mirror  ftpadmin    512 Mar  3 13:43 1.4.1
drwxrwxr-x   5 mirror  ftpadmin    512 Mar 11 09:53 1.4.2
drwxrwxr-x   3 mirror  ftpadmin    512 Oct 26 06:45 1.4K
drwxrwxr-x   3 mirror  ftpadmin    512 Mar  9 ppp21:43 1.4S
-rw-rw-r--   1 mirror  ftpadmin    252 May 29  1998 README
drwxrwxr-x  56 mirror  ftpadmin  62464 Apr  8 23:07 distfiles
lrwxr-xr-x   1 mirror  ftpadmin     24 Sep 29  1999 pkgsrc -> ../NetBSD-current/pkgsrc
lrwxr-xr-x   1 mirror  ftpadmin     41 Sep 29  1999 pkgsrc.tar.gz -> ../NetBSD-current/tar_files/pkgsrc.tar.gz
その中の pkgsrc.tar.gz を持って来る (5.8MBytes)
予め取得してあるものは、/usr/pkgsrc/distfiles に置いておく
cd /usr
tar  zxvf SOMEWHERE/pkgsrc.tar.gz
で開けると /usr/pkgsrc/www/communicator のように入る (結局、どこかで root 権限が必要になるので、root で作業する)
/usr/pkgsrc と /usr/pkg を全て自分のものにしておけば root は不要か も知れない。(が、もし setuid のものあると、動かないので、root を 使う方が無難だろう) 以下のものが自動的に入る
emulators/suse_base
emulators/suse_compat
emulators/suse_libc5
emulators/suse_linux
emulators/suse_x11
emulators/suse_xforms
devel/gmake
devel/gettext
misc/rpm

本当は、

tar  zxvf SOMEWHERE/pkgsrc.tar.gz 
として、全部開けてしまえばいいのだけれど、

tar  zxvf SOMEWHERE/pkgsrc.tar.gz  \
pkgsrc/emulators/{suse_base,suse_compat,suse_libc5,suse_linux,suse_x11,suse_xforms} \
pkgsrc/devel/{gmake,gettext} \
pkgsrc/misc/rpm \
pkgsrc/www/{communicator,navigator} \
pkgsrc/mk

www/communicator で make とすると次のように言われてしまう
mak@scgj$LOGO17:36:23/1004%(...www/communicator)# make
===> Validating dependencies for communicator-4.7
Your package tools need to be updated to 2000/02/02 versions.
The installed package tools were last updated on .
Please make and install the pkgsrc/pkgtools/pkg_install package.

tar  zxvf SOMEWHERE/pkgsrc.tar.gz  pkgsrc/pkgtools 
してから、
pushd /usr/pkgsrc/pkgtools/
make
 libtool-1.2 が入る。(古いなぁ)
(/usr/pkgsrc/distfiles/libtool-1.2.tar.gz を使う)

pushd /usr/pkgsrc/pkgtools/pkg_install
make

一つ上って pkgtools で make
mak@scgj$LOGO17:46:48/1004%(...pkgsrc/pkgtools)# make
===> package gensolpkg
===> gensolpkg-1.6 does not work on NetBSD-1.4.1-i386
 
pkg_tool で make install する必要があった。

Perl 5.004_04

perl がないと.. と言っているが、Perl5.004_04 なのですよね。 site-perl の位置と -U d_setlocale が設定されない ... CONFIGURE_SCRIPT= ./Configure -U d_setlocale としておく これも入れる pkgsrc/lang/perl5

www/communicator

make する。 make install すると、
===> Registering installation for communicator-4.7
communicator-4.7 requires installed package suse_base-6.3
communicator-4.7 requires installed package suse_compat-6.3
communicator-4.7 requires installed package suse_libc5-6.3
communicator-4.7 requires installed package suse_linux-6.3
communicator-4.7 requires installed package suse_x11-6.3
communicator-4.7 requires installed package suse_xforms-6.3
というのだけれど、これは入っていることを確認しているのか 必要だと言っているのか。どうも確認をしているだけのようだ。 /usr/pkg/bin を $PATH に入れておいて、 communicator と入力すると、動く。

その他

これは alpha i386 sparc しか動かない。
http://www.suse.com って何か知らない。

Last Update
19:53:05 03/12/08
CCBot/2.0 (https://commoncrawl.org/faq/)
Apache/2.0.65 (Unix) mod_ssl/2.0.65 OpenSSL/1.0.1g DAV/2 PHP/5.4.26
Count.cgi
(since 2000/04/09)